TODO #13597

Twitterプラグインをインストールすると管理画面が表示されなくなる

- evian約2年前に追加. 約2年前に更新.

ステータス:解決開始日:
優先度:今すぐ期日:
担当者:江頭 竜二進捗率:

100%

カテゴリ:-
対象バージョン:-

説明

発生環境
MAMP PRO v3.5.2
PHP5.6.10
MySQL5.5.42

発生手順
  1. baserMarketからダウンロードしたTwitterプラグイン( https://market.basercms.net/products/detail.php?product_id=18 )を解凍して、/lib/Baser/Plugin に設置する。
  2. プラグイン管理>プラグイン一覧から、Twitterプラグインを有効にする。
  3. 管理画面が表示されなくなる。

Twitterプラグインを削除すると管理画面の表示が復旧する。


関係しているリビジョン

リビジョン 741dc415
江頭 竜二約2年前に追加

fix #13597 Twitterプラグインをインストールすると管理画面が表示されなくなる問題を改善

プラグインについて後方互換が足りない部分を非推奨として追加

リビジョン e9f1a393
江頭 竜二約2年前に追加

fix #13597 インストール時に Deprecated メッセージが表示されてしまう問題を改善

履歴

#1 江頭 竜二約2年前に更新

  • 優先度通常 から 今すぐ に変更

#2 江頭 竜二約2年前に更新

  • ステータス担当 から 解決 に変更
  • 進捗率0 から 100 に変更

更新履歴 basercms:basercms|commit:741dc4151780f3b5e0c009f41fbb44d5bfb95b44 で適用されました。

#3 - evian約2年前に更新

  • ステータス解決 から 確認 に変更

発生環境
MAMP PRO v3.5.2
PHP7.0.8
MySQL5.5.42

こちらが適用されたdev-4をzipダウンロードして、ローカル環境に新規インストールしたところ、Step5で下記のエラーが出ました。

Deprecated (16384): メソッド:Plugin::initDb()は、バージョン 4.0.0 より非推奨となりました。バージョン 5.0.0 で削除される予定です。initDbの引数が変更になりました。第一引数にプラグイン名を設定してください。元の第一引数は不要です。 [CORE/Baser/Model/Plugin.php, line 62]
Deprecated (16384): メソッド:Plugin::initDb()は、バージョン 4.0.0 より非推奨となりました。バージョン 5.0.0 で削除される予定です。initDbの引数が変更になりました。第一引数にプラグイン名を設定してください。元の第一引数は不要です。 [CORE/Baser/Model/Plugin.php, line 62]
Deprecated (16384): メソッド:Plugin::initDb()は、バージョン 4.0.0 より非推奨となりました。バージョン 5.0.0 で削除される予定です。initDbの引数が変更になりました。第一引数にプラグイン名を設定してください。元の第一引数は不要です。 [CORE/Baser/Model/Plugin.php, line 62]

#4 江頭 竜二約2年前に更新

こちらは仕様です。
制作・開発モードをノーマルモードにすると問題なく動きます。
メッセージを出さないようにするには、Twitter側の対応が必要です。

#5 江頭 竜二約2年前に更新

あ、インストール時なんですね。
Twitterプラグインは設置済の状態でしょうか?
もし、そうであれば、しかたないところです。

#6 - evian約2年前に更新

ダウンロードして解凍したフォルダを設置しただけで新規インストールしたので、
Twitterプラグインは入っていない状態です。

#7 江頭 竜二約2年前に更新

了解しました。確認します。
しかし、メッセージもおかしいですね。こちらも調整します。

#8 - evian約2年前に更新

追記
インストール自体は完了していて、管理画面URLから普通にログインできました。

#9 江頭 竜二約2年前に更新

  • ステータス確認 から 解決 に変更

更新履歴 basercms:basercms|commit:e9f1a393593956e35abc530e2dc49f9f42304319 で適用されました。

他の形式にエクスポート: Atom PDF