TODO #15978

php7.1.0の環境でbaserCMS4.0.1をインストールするとエラーが発生する

村上 彬1年以上前に追加. 約1ヶ月前に更新.

ステータス:担当開始日:
優先度:急いで期日:
担当者:-進捗率:

0%

カテゴリ:-
対象バージョン:-

説明

フォーラムに下記問い合わせが寄せられました。
http://forum.basercms.net/modules/newbb/viewtopic.php?topic_id=2768&forum=3

ローカル環境(mac、mamp)で検証したところ同様の事象を確認しました。
エラー表示の後、管理画面「/admin」にはアクセスすることが可能でした。
動作を見る限りあらかた動くようですがブログ記事にアップローダを使用して記事を添付できない、コンテンツ一覧でドラッグ&ドロップで並び替える際成功しているようだが失敗のアラート表示がされるなどの事象を確認しました。

その他にも潜在的に不具合が存在している可能性があるため調査が必要かと思います。

履歴

#1 坂口 昌己1年以上前に更新

PHP7.1に対応するには、CakePHPのバージョンアップが必要そうです。
(baerCMS4.0.1 はCakePHP 2.8.5)

https://bakery.cakephp.org/2016/12/23/cakephp_294_released.html

CakePHP 2.9.4 Released
PHP 7.1 Support

CakePHP 2.9.4 has all tests are passing in PHP7.1. PHP 7.1 is now an officially supported version for 2.x.

#2 江頭 竜二1年以上前に更新

  • 対象バージョン4.0.2 から 4.0.3 に変更

#3 江頭 竜二1年以上前に更新

  • 対象バージョン4.0.3 から 4.0.4 に変更

#4 江頭 竜二1年以上前に更新

  • 対象バージョン4.0.4 から 4.0.5 に変更

#5 江頭 竜二約1年前に更新

  • 対象バージョン4.0.5 から 4.0.6 に変更

Cakeのバージョンアップがさくっといかないので、一旦、見送ります。
※ 4.0.6 では、2.10 に対応したい

#6 ナカエ -約1年前に更新

インストール時のエラー自体は直しました。まあCakeのPaginatorHelperなどは動かないのですが
https://github.com/baserproject/basercms/pull/615

#7 江頭 竜二12ヶ月前に更新

  • 対象バージョン4.0.6 から 188 に変更

#8 江頭 竜二12ヶ月前に更新

  • 対象バージョン188 から 4.1.0 に変更

#9 江頭 竜二約1ヶ月前に更新

  • 優先度通常 から 急いで に変更

#10 江頭 竜二約1ヶ月前に更新

  • 対象バージョン を削除 (4.1.0)

他の形式にエクスポート: Atom PDF